<!DOCTYPE html><html class="no-js" lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><script src="/cdn-cgi/apps/head/RUWOKfXG8qEgHFKNv-agWabhJLU.js"></script><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="https://www.tesfanews.net/xmlrpc.php"><meta name="google-site-verification" content="aMXrl5jWmc3xc_7RkpnSlvMhfj9X1iz5PvPYAtNWYRo" /><link media="all" href="https://www.tesfanews.net/wp-content/cache/autoptimize/css/autoptimize_6b95168a3ae454bc25283244fb0aa02d.css" rel="stylesheet" /><link media="screen" href="https://www.tesfanews.net/wp-content/cache/autoptimize/css/autoptimize_d4474131ee5150e7334a858c372bcf7e.css" rel="stylesheet" /><title>Egypt, Eritrea Leaders Discuss Developments in Horn of Africa, Red Sea</title><meta name="description" content="President al-Sisi of Egypt received Eritrean counterpart Isaias Afwerki at Itihadiyah Presidential Palace to discuss regional developments and bilateral relations." /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.tesfanews.net/egypt-eritrea-leaders-discuss-horn-africa-red-sea-developments/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Egypt, Eritrea Leaders Discuss Developments in Horn of Africa, Red Sea" /><meta property="og:description" content="President al-Sisi received Eritrean counterpart Isaias Afwerki at Itihadiyah Presidential Palace to discuss regional developments and bilateral relations." /><meta property="og:url" content="https://www.tesfanews.net/egypt-eritrea-leaders-discuss-horn-africa-red-sea-developments/" /><meta property="og:site_name" content="TesfaNews" /><meta property="article:publisher" content="https://www.facebook.com/TesfaNewsPage/" /><meta property="article:published_time" content="2020-07-06T17:45:40+00:00" /><meta property="article:modified_time" content="2020-07-06T17:47:10+00:00" /><meta property="og:image" content="https://i1.wp.com/www.tesfanews.net/wp-content/uploads/2020/07/PIA-Egypt_2020_5.jpg?fit=840%2C450&#038;ssl=1" /><meta property="og:image:width" content="840" /><meta property="og:image:height" content="450" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@tesfanews" /><meta name="twitter:site" content="@tesfanews" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.tesfanews.net/#website","url":"https://www.tesfanews.net/","name":"TesfaNews","description":"Daily Eritrea News and Views","potentialAction":[{"@type":"SearchAction","target":"https://www.tesfanews.net/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.tesfanews.net/egypt-eritrea-leaders-discuss-horn-africa-red-sea-developments/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/www.tesfanews.net/wp-content/uploads/2020/07/PIA-Egypt_2020_5.jpg?fit=840%2C450&ssl=1","width":840,"height":450},{"@type":"WebPage","@id":"https://www.tesfanews.net/egypt-eritrea-leaders-discuss-horn-africa-red-sea-developments/#webpage","url":"https://www.tesfanews.net/egypt-eritrea-leaders-discuss-horn-africa-red-sea-developments/","name":"Egypt, Eritrea Leaders Discuss Developments in Horn of Africa, Red Sea","isPartOf":{"@id":"https://www.tesfanews.net/#website"},"primaryImageOfPage":{"@id":"https://www.tesfanews.net/egypt-eritrea-leaders-discuss-horn-africa-red-sea-developments/#primaryimage"},"datePublished":"2020-07-06T17:45:40+00:00","dateModified":"2020-07-06T17:47:10+00:00","author":{"@id":"https://www.tesfanews.net/#/schema/person/a4187131810451e0352a19d229b8cb2e"},"description":"President al-Sisi of Egypt received Eritrean counterpart Isaias Afwerki at Itihadiyah Presidential Palace to discuss regional developments and bilateral relations.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.tesfanews.net/egypt-eritrea-leaders-discuss-horn-africa-red-sea-developments/"]}]},{"@type":["Person"],"@id":"https://www.tesfanews.net/#/schema/person/a4187131810451e0352a19d229b8cb2e","name":"TesfaNews","image":{"@type":"ImageObject","@id":"https://www.tesfanews.net/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/33515e690cef2cd281d26488987e682c?s=96&d=wavatar&r=g","caption":"TesfaNews"},"description":"TesfaNews is an independent online magazine with quality news, views and information materials on Eritrea."}]}</script> <link rel='dns-prefetch' href='//secure.gravatar.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link href='https://cdn.shortpixel.ai' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="TesfaNews &raquo; Feed" href="https://feeds.feedburner.com/tesfanews/mZyI" /><link rel="alternate" type="application/rss+xml" title="TesfaNews &raquo; Comments Feed" href="https://www.tesfanews.net/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="TesfaNews &raquo; Egypt, Eritrea Leaders Discuss Developments in Horn of Africa, Red Sea Comments Feed" href="https://www.tesfanews.net/egypt-eritrea-leaders-discuss-horn-africa-red-sea-developments/feed/" /><link href="https://www.tesfanews.net/wp-content/uploads/2017/08/TN-fav.png" rel="icon"><link rel="apple-touch-icon-precomposed" href="https://www.tesfanews.net/wp-content/uploads/2017/08/TN-mobile.png"> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.tesfanews.net\/wp-includes\/js\/wp-emoji-release.min.js?nocache"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link crossorigin="anonymous" rel='stylesheet' id='tt-easy-google-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%7CMontserrat%3A700%7CMerriweather%3A700%2C300%7CLora%3Aitalic&#038;subset=latin%2Call&#038;nocache' type='text/css' media='all' /> <script type='text/javascript' src='https://www.tesfanews.net/wp-includes/js/jquery/jquery.js?nocache'></script> <script type='text/javascript'>var related_posts_js_options = {"post_heading":"h4"};</script> <link rel='https://api.w.org/' href='https://www.tesfanews.net/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.tesfanews.net/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.tesfanews.net/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.2" /><link rel='shortlink' href='https://wp.me/p1i9Dn-fsC' /><link rel="alternate" type="application/json+oembed" href="https://www.tesfanews.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tesfanews.net%2Fegypt-eritrea-leaders-discuss-horn-africa-red-sea-developments%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.tesfanews.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tesfanews.net%2Fegypt-eritrea-leaders-discuss-horn-africa-red-sea-developments%2F&#038;format=xml" /><meta name="generator" content="Site Kit by Google 1.10.0" /><link rel='dns-prefetch' href='//v0.wordpress.com' /><link rel='dns-prefetch' href='//jetpack.wordpress.com' /><link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//s1.wp.com' /><link rel='dns-prefetch' href='//s2.wp.com' /><link rel='dns-prefetch' href='//public-api.wordpress.com' /><link rel='dns-prefetch' href='//0.gravatar.com' /><link rel='dns-prefetch' href='//1.gravatar.com' /><link rel='dns-prefetch' href='//2.gravatar.com' /><link rel='dns-prefetch' href='//i0.wp.com' /><link rel='dns-prefetch' href='//i1.wp.com' /><link rel='dns-prefetch' href='//i2.wp.com' /><link rel='dns-prefetch' href='//c0.wp.com' /><meta name="google-site-verification" content="OhVkH8sOQDEOs7aWvnbbOdcwa0f-KDah-El0uF3_Y2g"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-4596033848606154",
enable_page_level_ads: true,
tag_partner: "site_kit"
});</script> <link rel="amphtml" href="https://www.tesfanews.net/egypt-eritrea-leaders-discuss-horn-africa-red-sea-developments/amp/"><!--[if lte IE 9]> <script src="https://www.tesfanews.net/wp-content/themes/mystery/assets/js/html5shiv.js"></script> <![endif]--> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-4596033848606154",
    enable_page_level_ads: true
  });</script> <link rel="icon" href="https://i2.wp.com/www.tesfanews.net/wp-content/uploads/2017/08/cropped-TN-retina-logo.png?fit=32%2C32&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i2.wp.com/www.tesfanews.net/wp-content/uploads/2017/08/cropped-TN-retina-logo.png?fit=192%2C192&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon" href="https://i2.wp.com/www.tesfanews.net/wp-content/uploads/2017/08/cropped-TN-retina-logo.png?fit=180%2C180&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i2.wp.com/www.tesfanews.net/wp-content/uploads/2017/08/cropped-TN-retina-logo.png?fit=270%2C270&#038;ssl=1" /></head><body class="post-template-default single single-post postid-59434 single-format-standard content-sidebar layout-content-sidebar" itemscope itemtype="http://schema.org/Blog"><div id="page" class="hfeed site clearfix"><header id="masthead" class="site-header" role="banner" itemscope="itemscope" itemtype="http://schema.org/WPHeader"><div id="primary-bar"><div class="container"><nav id="primary-nav" class="main-navigation" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"><ul id="primary-menu" class="primary-menu sf-menu"><li id="menu-item-48712" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48712"><a href="https://www.tesfanews.net/eritv/">ERI-TV (Live)</a></li><li id="menu-item-35282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35282"><a href="https://www.tesfanews.net/donate/">Donate</a></li><li id="menu-item-35284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35284"><a href="https://www.tesfanews.net/disclaimer/">Disclaimer</a></li><li id="menu-item-35285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35285"><a href="https://www.tesfanews.net/contact-us/">Contact us</a></li></ul></nav><div class="header-search"><form method="get" class="searchform" id="search-form" action="https://www.tesfanews.net/" role="search"> <input type="text" class="field" name="s" id="s" placeholder="Search"> <button name="search" id="search"><i class="fa fa-search"></i></button></form></div></div></div><div class="site-branding clearfix"><div class="container clearfix"><div id="logo" itemscope itemtype="http://schema.org/Brand"> <a href="https://www.tesfanews.net" itemprop="url" rel="home"> <img itemprop="logo" src="https://cdn.shortpixel.ai/client/q_lossy,ret_img/https://www.tesfanews.net/wp-content/uploads/2017/08/TN-logo-17.png" alt="TesfaNews" /> </a></div><div class="header-ad"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4596033848606154" data-ad-slot="9458381239" data-ad-format="auto"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></div></div><div id="secondary-bar" class="clearfix"><div class="container"><nav id="secondary-nav" class="main-navigation" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"><ul id="secondary-menu" class="secondary-menu sf-menu"><li id="menu-item-40737" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-40737 home_item"><a href="https://www.tesfanews.net/"><i class="fa fa-home"></i> Home</a></li><li id="menu-item-35288" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35288"><a href="https://www.tesfanews.net/category/business/">Development</a></li><li id="menu-item-35287" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35287"><a href="https://www.tesfanews.net/category/ethiopia/">Ethiopia</a></li><li id="menu-item-56395" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56395"><a href="https://www.tesfanews.net/category/interview/">Interviews</a></li><li id="menu-item-35286" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-35286"><a href="https://www.tesfanews.net/category/news/">News</a></li><li id="menu-item-35289" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-35289"><a href="https://www.tesfanews.net/category/must-read/">Opinions</a><ul class="sub-menu"><li id="menu-item-56449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56449"><a href="https://www.tesfanews.net/category/must-read/amanuel-biedemariam/">Amanuel Biedemariam</a></li><li id="menu-item-56405" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56405"><a href="https://www.tesfanews.net/category/must-read/bereket-kidane/">Bereket Kidane</a></li><li id="menu-item-56450" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56450"><a href="https://www.tesfanews.net/category/must-read/fikrejesus-amhazion/">Fikrejesus Amhazion</a></li><li id="menu-item-56406" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56406"><a href="https://www.tesfanews.net/category/must-read/sophia-tesfamariam/">Sophia Tesfamariam</a></li></ul></li><li id="menu-item-35292" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-35292"><a href="https://www.tesfanews.net/category/photos/">Photos</a></li><li id="menu-item-35290" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35290"><a href="https://www.tesfanews.net/category/sport/">Sport</a></li><li id="menu-item-35294" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35294"><a href="https://www.tesfanews.net/category/press-release/">PR</a></li><li id="menu-item-35295" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35295"><a href="https://www.tesfanews.net/category/audio/">Audio</a></li><li id="menu-item-35291" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35291"><a href="https://www.tesfanews.net/category/video/">Video</a></li><li id="menu-item-35293" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35293"><a href="https://www.tesfanews.net/category/tigrinya/">ትግርኛ</a></li></ul></nav><div class="header-social"><a href="https://www.facebook.com/pages/TesfaNews/245177265511039" rel="tipsy" title="Facebook"><i class="fa fa-facebook"></i></a><a href="https://twitter.com/tesfanews" rel="tipsy" title="Twitter"><i class="fa fa-twitter"></i></a><a href="https://www.tesfanews.net/feed/" rel="tipsy" title="RSS"><i class="fa fa-rss"></i></a></div></div></div></header><div id="site-content" class="site-content"><main id="main" class="site-main container clearfix" role="main"><div id="primary" class="content-area"><div id="content" class="single"><article id="post-59434" class="post-59434 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-photos tag-diplomacy tag-egypt tag-ethiopia tag-gerd tag-president-isaias entry" itemscope="itemscope" itemtype="http://schema.org/BlogPosting" itemprop="blogPost"><header class="entry-header"> <span class="entry-category" itemprop="articleSection"> <a href="https://www.tesfanews.net/category/news/">News</a> </span><div class="post-nav"> <a href="https://www.tesfanews.net/president-isaias-working-visit-egypt-cairo/" rel="tipsy" title="Previous Post"><i class="fa fa-angle-left"></i></a> <a href="https://www.tesfanews.net/egypt-eritrea-leaders-discuss-horn-africa-red-sea-developments/" rel="tipsy" title="Next Post"><i class="fa fa-angle-right"></i></a></div></header><h1 class="page-title" itemprop="headline">Egypt, Eritrea Leaders Discuss Developments in Horn of Africa, Red Sea</h1><div class="entry-meta"> <img alt='TesfaNews' src='https://secure.gravatar.com/avatar/33515e690cef2cd281d26488987e682c?s=48&#038;d=wavatar&#038;r=g' srcset='https://secure.gravatar.com/avatar/33515e690cef2cd281d26488987e682c?s=96&#038;d=wavatar&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' itemprop="image" /> <span class="entry-author author vcard" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"><a class="url fn n" href="https://www.tesfanews.net/author/admin/" itemprop="url"><span itemprop="name">TesfaNews</span></a></span> <span class="entry-date"> <time class="published" datetime="2020-07-06T12:45:40-05:00" itemprop="datePublished">July 6, 2020</time> </span> <span class="sep">|</span> <span class="entry-views"> 527 </span> <span class="sep">|</span> <span class="entry-comments"><a href="https://www.tesfanews.net/egypt-eritrea-leaders-discuss-horn-africa-red-sea-developments/#disqus_thread"><i class="fa fa-comment-o"></i></a></span> <span class="sep">|</span> <span class="entry-tags" itemprop="keywords"><i class="fa fa-tags"></i> <a href="https://www.tesfanews.net/tag/diplomacy/" rel="tag">Diplomacy</a>, <a href="https://www.tesfanews.net/tag/egypt/" rel="tag">Egypt</a>, <a href="https://www.tesfanews.net/tag/ethiopia/" rel="tag">Ethiopia</a>, <a href="https://www.tesfanews.net/tag/gerd/" rel="tag">GERD</a>, <a href="https://www.tesfanews.net/tag/president-isaias/" rel="tag">President Isaias</a></span></div><div class="entry-content" itemprop="articleBody"><h4>The two Presidents exchanged views on developments in the Horn of Africa and the Red Sea as well as the Grand Ethiopian Renaissance Dam.</h4><div id="metaslider-id-59414" style="max-width: 840px;" class="ml-slider-3-16-4 ml-slider-pro-2-16-0 metaslider metaslider-nivo metaslider-59414 ml-slider ms-theme-simply-dark has-dots-nav"><div id="metaslider_container_59414"><div class='slider-wrapper theme-default'><div class='ribbon'></div><div id='metaslider_59414' class='nivoSlider'><img src="https://i2.wp.com/www.tesfanews.net/wp-content/uploads/2020/07/PIA-Egypt_2020_3.jpg?resize=840%2C450&#038;ssl=1" height="450" width="840" title="PIA-Egypt_2020_3" alt="" class="slider-59414 slide-59418" data-recalc-dims="1" /><img src="https://i0.wp.com/www.tesfanews.net/wp-content/uploads/2020/07/PIA-Egypt_2020_2.jpg?resize=840%2C450&#038;ssl=1" height="450" width="840" title="PIA-Egypt_2020_2" alt="" class="slider-59414 slide-59419" data-recalc-dims="1" /><img src="https://i1.wp.com/www.tesfanews.net/wp-content/uploads/2020/07/PIA-Egypt_2020_1.jpg?resize=840%2C450&#038;ssl=1" height="450" width="840" title="PIA-Egypt_2020_1" alt="" class="slider-59414 slide-59420" data-recalc-dims="1" /><img src="https://i1.wp.com/www.tesfanews.net/wp-content/uploads/2020/07/PIA-Egypt_2020_4.jpg?resize=840%2C450&#038;ssl=1" height="450" width="840" title="PIA-Egypt_2020_4" alt="" class="slider-59414 slide-59428" data-recalc-dims="1" /><img src="https://i2.wp.com/www.tesfanews.net/wp-content/uploads/2020/07/PIA-Egypt_2020_7.jpg?resize=840%2C450&#038;ssl=1" height="450" width="840" title="PIA-Egypt_2020_7" alt="" class="slider-59414 slide-59431" data-recalc-dims="1" /><img src="https://i1.wp.com/www.tesfanews.net/wp-content/uploads/2020/07/PIA-Egypt_2020_5.jpg?resize=840%2C450&#038;ssl=1" height="450" width="840" title="PIA-Egypt_2020_5" alt="" class="slider-59414 slide-59430" data-recalc-dims="1" /><img src="https://i0.wp.com/www.tesfanews.net/wp-content/uploads/2020/07/PIA-Egypt_2020_6.jpg?resize=840%2C450&#038;ssl=1" height="450" width="840" title="PIA-Egypt_2020_6" alt="" class="slider-59414 slide-59429" data-recalc-dims="1" /></div></div></div></div><p>BY <a href="https://www.egypttoday.com/Article/1/89305/Egyptian-Eritrean-presidents-discuss-developments-in-Horn-of-Africa-Red" target="_blank" rel="noopener noreferrer"><strong>EGYPT TODAY</strong></a></p><p style="text-align: justify;"><span class="wpsdc-drop-cap">P</span>resident Abdel Fatah al-Sisi received on Monday Eritrean counterpart Isaias Afwerki at Itihadiyah Presidential Palace to discuss regional developments and bilateral relations.</p><p style="text-align: justify;">The guest president is on a three-day visit which will include a meeting between officials of both countries to exchange views on developments in the Horn of Africa and the Red Sea as well as the Grand Ethiopian Renaissance Dam.<span id="more-59434"></span></p><p style="text-align: justify;">The last visit by the Eritrean president to Egypt took place in June 2019. In their meeting, President Sisi stressed the importance of setting forth well-defined plans to push forward Egyptian-Eritrean cooperation at various levels.</p><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <ins class="adsbygoogle" style="display: block; text-align: center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-4596033848606154" data-ad-slot="2608524076"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p><p style="text-align: justify;">Sisi also underscored the need to overcome any obstacles to mutual cooperation, especially in infrastructure, energy, healthcare, trade, investment, and agricultural sectors.</p><p style="text-align: justify;">Welcoming the Eritrean president, Sisi lauded the robust historical ties between both sisterly African nations, Presidential Spokesman Bassam Rady said.</p><p style="text-align: justify;">He also asserted Egypt&#8217;s keenness to keep up the current momentum for stronger mutual ties, establish sustainable partnerships and maintain mutual coordination on regional as well as African issues, especially under Egypt&#8217;s current presidency of the African Union (AU), Rady added.</p><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <ins class="adsbygoogle" style="display: block; text-align: center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-4596033848606154" data-ad-slot="2608524076"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p><p style="text-align: justify;">For his part, Afwerki praised Egypt&#8217;s vital role to drive the development process and maintain peace and security in Africa, highlighting his country&#8217;s commitment to further cooperation in several sectors.</p><p style="text-align: justify;">He further applauded Egypt&#8217;s constructive efforts to ensure stability in the Horn of Africa.</p><p style="text-align: justify;">The meeting took up the latest regional developments, the spokesman noted, adding both leaders agreed to maintain intensified coordination on such developments, especially those related to the Horn of Africa, the situation in Sudan and Somalia, Red Sea security, and the Nile water.</p><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-59434" class="share-twitter sd-button share-icon" href="https://www.tesfanews.net/egypt-eritrea-leaders-discuss-horn-africa-red-sea-developments/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-59434" class="share-facebook sd-button share-icon" href="https://www.tesfanews.net/egypt-eritrea-leaders-discuss-horn-africa-red-sea-developments/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div id='jp-relatedposts' class='jp-relatedposts'><h3 class="jp-relatedposts-headline"><em>Related</em></h3></div></div><footer class="entry-footer clearfix"><div class="entry-share clearfix"><ul><li class="twitter"><a href="https://twitter.com/intent/tweet?text=Egypt, Eritrea Leaders Discuss Developments in Horn of Africa, Red Sea&url=https%3A%2F%2Fwww.tesfanews.net%2Fegypt-eritrea-leaders-discuss-horn-africa-red-sea-developments%2F" target="_blank"><i class="fa fa-twitter"></i>Twitter</a></li><li class="facebook"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.tesfanews.net%2Fegypt-eritrea-leaders-discuss-horn-africa-red-sea-developments%2F" target="_blank"><i class="fa fa-facebook"></i>Facebook</a></li><li class="google-plus"><a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.tesfanews.net%2Fegypt-eritrea-leaders-discuss-horn-africa-red-sea-developments%2F" target="_blank"><i class="fa fa-google-plus"></i>Google+</a></li><li class="linkedin"><a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.tesfanews.net%2Fegypt-eritrea-leaders-discuss-horn-africa-red-sea-developments%2F&title=Egypt, Eritrea Leaders Discuss Developments in Horn of Africa, Red Sea" target="_blank"><i class="fa fa-linkedin"></i>LinkedIn</a></li><li class="pinterest"><a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.tesfanews.net%2Fegypt-eritrea-leaders-discuss-horn-africa-red-sea-developments%2F&media=https%3A%2F%2Fwww.tesfanews.net%2Fwp-content%2Fuploads%2F2020%2F07%2FPIA-Egypt_2020_5.jpg" target="_blank"><i class="fa fa-pinterest"></i>Pinterest</a></li><li class="email"><a href="mailto:"><i class="fa fa-envelope-o"></i>Email</a></li></ul></div></footer></article><div id="disqus_thread"></div></div></div><div id="secondary" class="widget-area widget-primary sidebar2" role="complementary" aria-label="Primary Sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><aside id="wgs_widget-2" class="widget widget_wgs_widget"><div class="wgs_wrapper"><div class="gcse-search" data-resultsUrl="https://www.tesfanews.net/search_gcse/"></div></div></aside><aside id="mystery-ads-2" class="widget widget-mystery-ad widget_ads"><div class="adwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4596033848606154" data-ad-slot="9458381239" data-ad-format="auto"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="recent-posts-5" class="widget widget_recent_entries"><h3 class="widget-title">Recent Posts</h3><ul><li> <a href="https://www.tesfanews.net/egypt-eritrea-leaders-discuss-horn-africa-red-sea-developments/" aria-current="page">Egypt, Eritrea Leaders Discuss Developments in Horn of Africa, Red Sea</a></li><li> <a href="https://www.tesfanews.net/president-isaias-working-visit-egypt-cairo/">President Isaias on Working Visit to Egypt (Update)</a></li><li> <a href="https://www.tesfanews.net/zack-dairy-farm-products-eritrea/">Eritrea: Zack Dairy Farm Products</a></li><li> <a href="https://www.tesfanews.net/eritrea-covid19-guidelines-partial-re-opening-schools/">Guidelines on Partial Reopening of Schools</a></li></ul></aside><aside id="mystery-ads-9" class="widget widget-mystery-ad widget_ads"><div class="adwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-format="fluid" data-ad-layout="in-article" data-ad-client="ca-pub-4596033848606154" data-ad-slot="2608524076"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="mystery-ads-5" class="widget widget-mystery-ad widget_ads"><div class="adwidget"><a class="twitter-timeline" data-width="300" data-height="800" href="https://twitter.com/tesfanews?ref_src=twsrc%5Etfw">Tweets by tesfanews</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div></aside><aside id="text-12" class="widget widget_text"><div class="textwidget"><div class="feedgrabbr_widget" id="fgid_cb4c473a33c619890d3741ce7"></div> <script>if (typeof(fg_widgets)==="undefined") fg_widgets = new Array();fg_widgets.push("fgid_cb4c473a33c619890d3741ce7");</script> <script src="https://www.feedgrabbr.com/widget/fgwidget.js"></script></div></aside></div></main></div><div class="clearfix"></div><footer id="footer" class="site-footer clearfix footer-dark" role="contentinfo" itemscope="itemscope" itemtype="http://schema.org/WPFooter"><div class="container"><div class="footer-column footer-column-1"></div><div class="footer-column footer-column-2"></div><div class="footer-column footer-column-3"></div><div class="footer-column footer-column-4"></div></div><div id="site-bottom" class="clearfix"><div class="container"><nav id="footer-nav" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"><ul id="menu-tn-menu3" class="menu"><li id="menu-item-48713" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48713"><a href="https://www.tesfanews.net/eritv/">ERI-TV (Live)</a></li><li id="menu-item-35296" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35296"><a href="https://www.tesfanews.net/donate/">Donate</a></li><li id="menu-item-35298" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35298"><a href="https://www.tesfanews.net/disclaimer/">Disclaimer</a></li><li id="menu-item-35299" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35299"><a href="https://www.tesfanews.net/contact-us/">Contact us</a></li></ul></nav><div class="copyright"><span style="color: #666666; font-family: Roboto, sans-serif; font-size: 14px;">© </span>2010 - 2020.  <span style="color: #666666; font-family: Roboto, sans-serif; font-size: 14px;">All rights reserved. TesfaNews is an Eritrea - Ethiopia Focused News and Views Blog.</span></div></div></div></footer></div> <script type="text/javascript">jQuery(document).ready(function(){jQuery('.description').before('<span><!--INFOLINKS_OFF--></span>');jQuery('.description').after('<span><!--INFOLINKS_ON--></span>');jQuery('#headerimg').before('<span><!--INFOLINKS_OFF--></span>');jQuery('#headerimg').after('<span><!--INFOLINKS_ON--></span>');jQuery('h1').before('<span><!--INFOLINKS_OFF--></span>');jQuery('h1').after('<span><!--INFOLINKS_ON--></span>');jQuery('h1').before('<span><!--INFOLINKS_OFF--></span>');jQuery('h1').after('<span><!--INFOLINKS_ON--></span>');});</script> <script type="text/javascript">var infolinks_pid = 192219; 
    var infolinks_plugin_version = "WP_3.2.2"; 
    var infolinks_resources = "//resources.infolinks.com/js";</script> <script type="text/javascript" src="//resources.infolinks.com/js/infolinks_main.js"></script> <div style="display:none"><div class="grofile-hash-map-33515e690cef2cd281d26488987e682c"></div></div> <script>document.documentElement.className = 'js';</script> <script type="text/javascript">var disqus_shortname = 'tesfanews';
		    (function () {
		        var s = document.createElement('script'); s.async = true;
		        s.type = 'text/javascript';
		        s.src = '//' + disqus_shortname + '.disqus.com/count.js';
		        (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
		    }());</script> <script type="text/javascript">jQuery(document).ready( function() { jQuery.post( "https://www.tesfanews.net/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "2027c940e0", post_id : 59434 } ); } );</script> <script type="text/javascript">window.WPCOM_sharing_counts = {"https:\/\/www.tesfanews.net\/egypt-eritrea-leaders-discuss-horn-africa-red-sea-developments\/":59434};</script> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-36538707-1', 'auto');
  ga('send', 'pageview');</script> <script type='text/javascript'>var scriptParams = {"google_search_engine_id":"004100180716079994633:tvecdqdbbs8"};</script> <script type='text/javascript'>var countVars = {"disqusShortname":"tesfanews"};</script> <script type='text/javascript'>var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"59434 https:\/\/www.tesfanews.net\/?p=59434","disqusShortname":"tesfanews","disqusTitle":"Egypt, Eritrea Leaders Discuss Developments in Horn of Africa, Red Sea","disqusUrl":"https:\/\/www.tesfanews.net\/egypt-eritrea-leaders-discuss-horn-africa-red-sea-developments\/","postId":"59434"};</script> <script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?nocache'></script> <script type='text/javascript'>var WPGroHo = {"my_hash":""};</script> <script type='text/javascript'>var metaslider_59414 = function($) {
            $('#metaslider_59414').nivoSlider({ 
                boxCols:7,
                boxRows:5,
                pauseTime:3000,
                effect:"random",
                controlNav:true,
                directionNav:true,
                pauseOnHover:true,
                animSpeed:600,
                prevText:'<svg labelledBy=\'simply-dark-prev-title\' aria-hidden=\'true\' role=\'img\' xmlns=\'http://www.w3.org/2000/svg\' viewBox=\'0 0 256 512\' data-fa-i2svg=\'\'><title id=\'simply-dark-prev-title\'>Previous Slide</title><path fill=\'currentColor\' d=\'M31.7 239l136-136c9.4-9.4 24.6-9.4 33.9 0l22.6 22.6c9.4 9.4 9.4 24.6 0 33.9L127.9 256l96.4 96.4c9.4 9.4 9.4 24.6 0 33.9L201.7 409c-9.4 9.4-24.6 9.4-33.9 0l-136-136c-9.5-9.4-9.5-24.6-.1-34z\'></path></svg>',
                nextText:'<svg labelledBy=\'simply-dark-next-title\' aria-hidden=\'true\' role=\'img\' xmlns=\'http://www.w3.org/2000/svg\' viewBox=\'0 0 256 512\' data-fa-i2svg=\'\'><title id=\'simply-dark-next-title\'>Next Slide</title><path fill=\'currentColor\' d=\'M224.3 273l-136 136c-9.4 9.4-24.6 9.4-33.9 0l-22.6-22.6c-9.4-9.4-9.4-24.6 0-33.9l96.4-96.4-96.4-96.4c-9.4-9.4-9.4-24.6 0-33.9L54.3 103c9.4-9.4 24.6-9.4 33.9 0l136 136c9.5 9.4 9.5 24.6.1 34z\'></path></svg>',
                slices:15,
                manualAdvance:false
            });
            $(document).trigger('metaslider/initialized', '#metaslider_59414');
        };
        var timer_metaslider_59414 = function() {
            var slider = !window.jQuery ? window.setTimeout(timer_metaslider_59414, 100) : !jQuery.isReady ? window.setTimeout(timer_metaslider_59414, 1) : metaslider_59414(window.jQuery);
        };
        timer_metaslider_59414();</script> <script type='text/javascript'>var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};</script> <script type='text/javascript'>var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});</script> <script type="text/javascript">let isGutenberg = true;
	let miniAudioPlayer_replaceDefault = 1;
	let miniAudioPlayer_excluded = "map_excuded";
	let miniAudioPlayer_replaceDefault_show_title = 1;

	let miniAudioPlayer_defaults = {
				inLine:true,
                width:"400",
				skin:"black",
				animate:true,
				volume:.2,
				autoplay:false,
				showVolumeLevel:true,
				allowMute: true,
				showTime:true,
				id3:false,
				showRew:true,
				addShadow: false,
				downloadable:false,
				downloadPage: null,
				swfPath:"https://www.tesfanews.net/wp-content/plugins/wp-miniaudioplayer/js/",
				onReady: function(player, $controlsBox){
				   if(player.opt.downloadable && player.opt.downloadablesecurity && !false){
				        jQuery(".map_download", $controlsBox).remove();
				   }
				}
		};

    function initializeMiniAudioPlayer(){
         jQuery(".mejs-container a").addClass(miniAudioPlayer_excluded);
         jQuery("a[href*='.mp3'] ,a[href*='.m4a']").not(".map_excuded").not(".wp-playlist-caption").mb_miniPlayer(miniAudioPlayer_defaults);
    }

    //if(1)
        jQuery("body").addClass("map_replaceDefault");

	jQuery(function(){
     // if(1)
         setTimeout(function(){replaceDefault();},10);
      
      initializeMiniAudioPlayer();
      jQuery(document).ajaxSuccess(function(event, xhr, settings) {
        initializeMiniAudioPlayer();
      });
	});</script> <script type="text/javascript">$(document).ready(function(){
			$('#primary-menu').slicknav({
				prependTo:'#primary-bar',
				label: "PAGES"
			});
			$('#secondary-menu').slicknav({
				prependTo:'#secondary-bar',
				label: "CATEGORIES"			
			});	
		});</script> <script type='text/javascript' src='https://stats.wp.com/e-202028.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.6.1',blog:'19103277',post:'59434',tz:'-5',srv:'www.tesfanews.net'} ]);
	_stq.push([ 'clickTrackerInit', '19103277', '59434' ]);</script> <script defer src="https://www.tesfanews.net/wp-content/cache/autoptimize/js/autoptimize_362f8fafdc926d3aab2a64e26f7cd28e.js"></script></body></html>